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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates the procedure has
only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown (e.g., “copy
file1 ” means type the word copy, then type a space, then type file1).

o On-screen prompts and messages, names of options and text fields, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys from the computer keyboard. For example, “Press Enter ” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics (e.g., “copyfile name” means type the word copy, then type a space, then
type the name of the file).

l The plus sign (+) is used between keyboard keys to indicate that both keys should be
pressed at the same time (e.g., “Press Shift +F1 ” means to press Shift and, while holding
it down, press F1). Always depress the modifier key or keys first (e.g., Shift, Ctrl, Alt, or
Ctrl +Shift), continue to hold it/them down, then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and
contains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Layout > Interface Ground "
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This instruction means click the Interface Ground command from the Layout tab. An
image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an
application arranged by category such File, Edit, View, Project, etc. An example of a
typical user interaction is as follows:

"From the Filemenu, selectOpen Examples" means click the Filemenu and select
Open Examples from the drop-down menu.

l Another alternative is to right-click and select from the shortcut menu. An example of a
typical user interaction is as follows:

“Right-click and select Assign Excitation >Wave Port” means select an object, right-
click, and click an option from the shortcut menu that appears.

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. This information can also be obtained by contacting an Ansys
account manager.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps are taken
or what stages the simulation reached, including software files as applicable. This allows more
rapid and effective debugging.

Help Menu

From the Help menu, select Help and choose from the following:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1 to open the selected help for the active product.

Press F1 while the cursor is pointing at a menu command or while a particular window tab is
open. In this case, the help page associated with the command or open window is displayed
automatically.
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1 - Introduction
Complete theGetting Started with HFSS 3D Layout: Low Pass Filter guide to create a low
pass filter in HFSS 3D Layout, then analyze the design. The low pass filter model consists of
three layers (i.e., a ground layer, a dielectric layer, and a signal layer). The user will need to
define the layers, assign a custommaterial to the dielectric layer, draw the model, define the
ports, and set up the solution. After solving the model, the user will review the S matrix results,
plot the return loss, create a Smith chart, a current density overlay, a far field display, and
animate the results.

Note:

For more information refer to the HFSS 3D Layout Simulator in the main help.

The following topics cover the physical design and EM analysis of a low-pass filter, specifically
the following subtopics:

l How to start the software and explore the HFSS 3D Layout tools
l How to use the ribbon, menu, and shortcut menu
l Terms and concepts essential to the simulation of an HFSS 3D Layout design
l How to add a custom-defined dielectric material to a design
l How to create a report to display simulation results

Note:

In many cases, there are multiple ways to access a tool or reach a particular window.
To keep this guide concise and easy to follow, only one method is described for each
step. If an alternative method offers a specific advantage or is better suited to a
scenario, it will be noted accordingly.

Setting General Options
Before inserting a design into the project, follow these steps to ensure the Electronics Desktop
options are set correctly for this exercise.

1. From the Desktop ribbon tab, clickGeneral Options.
2. In the tree on the left side of theOptions window, expand theGeneral group and select

the Default Units subgroup.
3. Selectmm from the Length drop-down menu to use millimeters as the default length unit.
4. From theOptions tree, select the Layout Editor > Snapping subgroup.

Introduction 1-1
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5. From the Targets area, clear theGrid option and ensure that your other selected options
match the following settings:

6. From theOptions tree, select the Layout Editor > Display subgroup.
7. In theGrid area, enter 10 mm in theMajor field and 1 mm in theMinor field, making sure

the unit used for each is millimeter (i.e., mm), the default setting.

Introduction 1-2
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8. ClickOK to close theOptions window.

Create the Model
From here, continue to the following topics to define the stackup layers (i.e., topology) of the
model, draw the geometry of the filter, and assign the excitation ports.

l Insert Layers
l Draw the Model Geometry
l Assign the Ports

Insert Layers
Follow these steps to insert layers in an HFSS 3D Layout design.

Introduction 1-3
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1. From the Layout tab, click Layers dialog to open the Edit Layers window.

2. Ensure Laminate is selected from the Stackup area > Type drop-down menu.

Add a Ground Layer to the Layer Table

Note:

When adding the first layer to the layers table, the actions of Insert above and Insert
below are identical. Once there are one or more layers in the table, the Insert above
and Insert below options will be inactive until a layer is selected from the table. After
selecting a layer from the table, select Layer >where to add the new layer (i.e.,
Insert above or below the highlighted layer).

Introduction 1-4
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1. Click Layer and select either Insert above or Insert below to open the Add Stackup
Layer window.

2. In the Add Stackup Layer window, do the following:
a. Enter g1 in the Name field.
b. Select signal from the Type drop-down menu.
c. ClickOK to close the Add Stackup Layer window add the new infinite ground layer

to the layer table.

Note:

The material copper is automatically assigned to signal layers.
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3. Ensure the box in the Rough column is not checked.

Note:

If the Rough box is checked, the surface roughness of the conductors is taken
into account when approximating the impedance of the signal traces. However,
surface roughness is ignored for ground layers. Removing the check from the
box prevents a warning to that effect during validation and solution setup.

4. If applicable, add the Negative column to the table. Right-click any column header (e.g.,
Name, Type,Material, et cetera) to open the shortcut menu. Then select Negative. The
Negative column will appear in the table.

5. Check the box in the Negative column.

Note:

Checking the box in the Negative column identifies the layer as a ground plane
layer. Any object drawn on a negative layer becomes a cutout in the ground layer
(conductor removed). However, no objects can be drawn on the g1 layer for this
model.
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Add a Dielectric Layer to the Layer Table
6. Right-click anywhere in the g1 layer and select Insert dielectric above. A new row

appears in the layer table (default Name, Dielectric).

7. In the new dielectric row, do the following:
a. In the Name field, replace dielectric with d1.
b. Ensure 1.6mm is entered in the Thickness field.
c. Select Edit from theMaterial drop-down menu to open the Select Definition

window.
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8. From the Select Definition window, do the following:
a. Click Add Material to open the View / Edit Material window.
b. In theMaterial Name field, replaceMaterial1 withmy_d1.
c. In the Relative Permittivity Value field, replace 1 with 2.2.
d. ClickOK to save changes, close the View / Edit Material window, and return to the

Select Definition window.
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e. ClickOK to close the Select Definition window.
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Add a Trace (Signal) Layer to the Layer Table
1. Right-click the d1 layer and select Insert signal above. A new row appears in the table.
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2. In the new signal row, do the following:
a. In the Name field, replace Signal with t1.
b. Check the box in the Rough column.

Make Changes to All Layers
1. From the Layer area, re-select Select All from the drop-down menu to highlight all three

rows. Ensure the Solver check box is not checked for all layers.
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2. Ensure the shading box in the Attributes area (i.e., the middle box) is checked. This
ensures that all objects will be shaded, rather than only outlined (i.e., wire frame).
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3. The Edit Layers window should now match the following example.

Note:

If the stackup is not arranged in the correct hierarchy, rearrange the layers by
clicking+dragging the selection handles in the left column. The t1 layer should
be at the top of the list, followed by the d1 layer in the middle, and the g1 layer on
the bottom.

4. Click Apply and Close to apply the layer definitions and close the Edit Layers window.

Continue to Draw the Model.

Draw the Model
Follow these steps to draw a model in the Layout Editor.

Introduction 1-13
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1. From the Layout tab, select t1 from the Active Layer drop-down menu.

2. From the Layout tab, click Draw rectangle.

3. Do not click+drag in the Layout Editor. Instead, move the cursor to the X coordinate
field at the bottom of the Layout Editor. Click inside the field, delete the coordinates
already present, and enter 0.

4. Press Tab to move the cursor to the Y coordinate field. Then type 0 in the field and press
Enter.

5. Press Tab until the cursor moves to the Delta X coordinate field. Then type 20 in the field.
6. Press Tab to move the cursor to the Delta Y coordinate field. Then type 4.6 in the field.
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7. Press Enter to complete the shape.
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Note:

Alternatively, create a rectangle to the exact dimensions required by first creating
a rectangle of any size, in any location, and then modifying its perimeters in the
Properties window. Coordinates entered via the coordinate fields specify
opposite corners of a rectangle. Alternatively, entering the Center,Width, and
Height of the proposed model in the Properties window determines the
dimensions of the model dependent from the rectangle's centroid. For example,
to create the rectangle described previously, do the following:

a. From the Layout tab, click Draw rectangle.
b. In the Layout Editor, click+drag to draw a rectangle.
c. Select the newly-drawn rectangle to display its perimeters in the

Properties window.
d. From the Properties window, do the following:

i. Ensure the 2 pt Description box is checked.
ii. Enter 0, 0 in the Pt A field.
iii. Enter 20, 4.6 in the Pt B field.
iv. Press Enter to save changes.

e.
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8. Create a second rectangle by doing the following:
a. From the Layout tab, click Draw rectangle.
b. Hover over the lower-right corner of the first rectangle until the cursor turns into a

square.

c. Click to snap the first corner of the second rectangle to that point. This effectively
designates the X, Y coordinates for the second rectangle 20, 0.

d. Click inside the Delta X coordinate field, delete the coordinates already present,
and enter 2.1.

e. Press Tab to move the cursor to the Delta Y coordinate field, Then type -10.5 in the
field.

f. Press Enter to complete the shape.

9. Create a third rectangle by doing the following:
a. From the Layout tab, click Draw rectangle.
b. Move the cursor to the X coordinate field at the bottom of the Layout Editor. Click

inside the field, delete the coordinates already present, and enter 21.05.
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c. Press Tab to move the cursor to the Y coordinate field. Then type 0 in the field and
press Enter.

d. Press Tab until the cursor moves to the Delta X coordinate field. Then type 21.7 in
the field.

e. Press Tab to move the cursor to the Delta Y coordinate field. Then type 0.7 in the
field.

f. Press Enter to complete the shape.

10. Click anywhere else in the Layout Editor to clear the current selection.
11. Spin the mouse wheel to Zoom In/Out on the space between the right edge of the first

rectangle, the top edge of the second rectangle, and the left edge of the third rectangle.
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12. Create a polygon by doing the following:

Note:

During step c, the cursor will become a triangle, since the snapping point
corresponds to the midpoint between the second rectangle's top edge and the
end point of two of the third rectangle's edges.

a. From the Layout tab, click Draw polygon.
b. Hover over the upper-right corner of the first rectangle until the cursor

turns into a square when the snap point is found. Then click (values
displayed in the X, Y coordinate fields will be 20.0, 4.6).

c. Click the upper-left corner of the third rectangle (values displayed in the
X, Y coordinate fields will be 21.05, 0.7)

d. Click the lower-left corner of the third rectangle (values displayed in the
X, Y coordinate text fields will be 21.05, 0.0)

e. Double-click the lower-right corner of the first rectangle (values
displayed in the X, Y coordinate text fields will be 20.0, 0.0)
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13. Press Ctrl+D to fit the drawing in the Layout Editor and clear the current selection.

14. Create duplicate copies of the first two rectangles and the new polygon by doing the
following:
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a. Press Ctrl+A to select all the objects.
b. While holding down Ctrl, click the third rectangle to deselect it. The first two

rectangles and the polygon should still be selected.
c. Press Ctrl+C to copy the selected objects.
d. Press Ctrl+V to paste a duplicate set of objects into the Layout Editor. The location

of the pasted objects moves as the mouse is moved.
e. Choose an area in the Layout Editor that does not overlap the original objects.

Then click to drop the new objects. Ensure the new objects remain selected for the
next step.

15. From the Layout tab, select Flip > About Y (or, from Draw, select Flip Horizontal).

16. Click+drag the selected objects to align with the bottom right corner of the third rectangle.
Once the cursor becomes a square, release-click and the objects will snap into place.
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17. Press Ctrl+D to fit the drawing in the Layout Editor and clear the current selection.
18. Create a fourth and final rectangle by doing the following:

a. From the Layout tab, click Draw rectangle.
b. Move the cursor to the X coordinate field at the bottom of the Layout Editor. Click

inside the field, delete the coordinates already present, and enter 29.3.
c. Press Tab to move the cursor to the Y coordinate field. Then type 0 in the field and

press Enter.
d. Press Tab until the cursor moves to the Delta X coordinate field. Then type 5.3 in

the field.
e. Press Tab to move the cursor to the Delta Y coordinate field. Then type -10.5 in the

field.
f. Press Enter to complete the shape.

19. Press Ctrl+A to select all objects.
20. From the Layout tab, select Unite to form all the rectangles and polygons into a single

object.
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Note:

It is not mandatory to unite the individual shapes. Where they meet, the solver
treats them as a contiguous object, regardless. However, uniting them produces
a simpler model and eliminates the possibility of accidentally dragging one shape
out of its proper position.

21. The design should match the following figure.

22. Click the object to select it. From the Properties window, replace the text in the Name
field with Filter. Then press Enter to save changes.
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23. Save the design, either by navigating to File > Save or clicking the Save button on any of
the ribbons.

Continue to Assign the Ports.

Create Edge Ports
Follow these steps to add two edge ports to the model.

1. To create the first port (i.e., Port1), press E to enter Select Edgesmode.

Note:

Once Select Edgesmode is active, the cursor changes: a diagonal line crosses
the tip of the arrow. Refer to the following step.
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2. Click the left side of the leftmost rectangle to select it.

3. From the Layout tab, select Create edge port.

4. To create the second port (i.e., Port2), press E to reenter Select Edgesmode.
5. Click the right side of the rightmost rectangle to select it.
6. From the Layout tab, select Create edge port.
7. Once a port is created, it appears in the Project Manager > Project Tree > [active

design folder] > Excitations folder. Right-click Port1 and select Rename.
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8. Rename Port1 to p1 and Port2 to p2.

Continue to Set Up an Analysis and Frequency Sweeps.
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2 - Set Up Solution and Analyze
This chapter contains the following topics:

l Set Up an Analysis and Frequency Sweeps
l Explore Disabling Sweeps and Setups
l View the Mesh
l Explore Dynamic Mesh Updates
l Run the Analysis

Set Up an Analysis and Frequency Sweeps
Solution setups are listed in the Project Manager window (i.e., expand the Project Tree > 
[active design folder] > Analysis folder). Follow these steps to add a new solution setup to the
project using basic, initial meshing tools. Then add, set up, and define an interpolating frequency
sweep and a discrete frequency sweep.

1. From the Simulation ribbon tab, navigate to HFSS > Advanced to open the HFSS Setup
window.

2. From the HFSS Setup window, click OK to accept the default settings and open the Edit

Set Up Solution and Analyze 2-1
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Frequency Sweep window.
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3. ClickOK to close the Setup window and open the Edit Frequency Sweep window.

Add an Interpolating Frequency Sweep

Note:

For interpolating sweeps, generating surface current data is only good for the last
adaptive pass of the solution frequency. Surface current data cannot be saved for fixed
mesh analyses.

1. Ensure Interpolating is selected from the Sweep Type drop-down menu.
2. Select Linear Count from the Distribution drop-down menu in the Frequency Sweeps

table.
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3. Enter 1.5 (GHz) in the Start column.

4. Enter 4.5 (GHz) in the Stop column.

5. Enter 201 in the Points field.

6. Click Preview to display the Sweep Points window.
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7. Click Close to return to the Edit Frequency Sweep window.

8. ClickOK to add the interpolating sweep and close the Edit Frequency Sweep window.
The sweep is added to the Project Manager window (i.e., expand the Project Tree >
[active design folder] > Analysis > Setup1).

Add a Discrete Frequency Sweep

Note:

For discrete sweeps, generating surface current data enables viewing of currents and
calculating far field effects at multiple frequencies in later post-precessing steps.

1. From the Project Manager window, expand the Project Tree > [active design folder]
> Analysis folder. Then right-click the analysis setup (e.g., Setup1) and select Add
Frequency Sweep to reopen the Edit Frequency Sweep window.

2. Select Discrete from the Sweep Type drop-down menu.
3. Select Linear Count from the Distribution drop-down menu in the Frequency Sweeps

table.

4. Enter 1.6 (GHz) in the Start column.
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5. Enter 2.6 (GHz) in the Stop column.

6. Enter 11 in the Points field.

7. In theOptions area, check the Save fields box.

8. ClickOK to add the discrete sweep and close the Edit Frequency Sweep window. The
sweep is added to the Project Manager window (i.e., expand the Project Tree > [active
design folder] > Analysis > Setup1).
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Continue to Explore Disabling Sweeps and Setups.

Deactivate/Activate Setups and Frequency Sweeps
If necessary, follow these instructions to activate or deactivate setup definitions and frequency
sweeps.

Deactivate or Enable a Setup Definition
From the Project Manager window, expand the Project Tree > [active design folder]
> Analysis folder. Then right-click Setup1 and select Disable Setup or Enable Setup. Only
one option will be available, depending on the current status of the setup (e.g., if the setup is
currently deactivated, only Enable Setup will appear in the shortcut menu).
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When an analysis setup is deactivated, any sweep associated with it has no effect, even if an
associated sweep is enabled.

Deactivate or Activate a Sweep Definition
From the Project Manager window, expand Setup1. Then right-click the sweep (e.g., Sweep1)
and select Disable Sweep Analysis or Enable Sweep Analysis. Only one option will be
available, depending on the current status of the setup (e.g., if the sweep is currently
deactivated, only Enable Sweep Analysis will appear in the shortcut menu).

Continue to View the Mesh.

View the Mesh
Follow these instructions to view the active design in a number of planar or 3D views.

From the Project Manager window, right-click Setup1 and select Pre-Process Geometry
> Display.
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A 3D mesh appears on the model in the Layout Editor.

The mesh will not display on a layer that is not visible.

Note:

A check mark appears adjacent to Display when the mesh is visible and disappears
when the mesh is hidden. To hide the mesh, uncheck Display.

Continue to Explore Dynamic Mesh Updates.

Choose Manual or Dynamic Mesh Updates
Objects in the Layout Editor can be stretched, compressed, skewed, and otherwise
manipulated by click+dragging the handles that surround the objects at the edges and
midpoints. By default, an object's mesh is not dynamically updated when the geometry of the
object is altered. The following instructions explain how to refresh the mesh manually or enable
Dynamic Mesh to update the mesh in real time.

Update the Mesh Manually
From the Project Manager window, right-click Setup1 and select Pre-Process Geometry
> Refresh.
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Important:

The consolidation of surfaces into a conformal mesh is skipped for dynamic and
tolerant meshing, including those with light weight geometries. This can lead to
overlapping surfaces in SBR+ simulations. The user should carefully avoid overlapping
surfaces or objects as SBR+ can produce unexpected results.

Enable Dynamic Updates
From the Project Manager window, right-click Setup1 and select Pre-Process Geometry
> Dynamic Updates.

Reset the Mesh After Using Undo or Redo
Even if Dynamic Updates is enabled, using the Undo or Redo commands to reset the
geometry of the design will disrupt the dynamic update process and the mesh will not
immediately conform to the reset geometry. Refresh to reset the mesh.

Note:

A check mark appears adjacent to Dynamic Updates when it is active and disappears
when Dynamic Updates is inactive. To deactivate Dynamic Updates, uncheck
Dynamic Updates.

Experiment with the Layout Editor by activating the mesh, enabling dynamic updates, and
then distorting or even adding new geometry to the model. Use the Select (O) and Handles 
(H) modes to update the cursor, then click+drag to alter the model, as applicable.

After experimenting, deactivate the mesh.

Continue to Run the Analysis.
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Run Analyses and Choose Analyses Options
To sequentially run all analysis setups and associated frequency sweeps in the active design,
navigate to the Project Manager window. Then right-click Analysis and select Analyze.

Note:

Alternatively, run a single setup or sweep by right-clicking the applicable setup or
sweep and select Analyze.

View Progress
View simulation progress in the Progress window.
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If necessary, perform the following actions during analysis: right-click within the Progress
window and select from: Abort, Clean Stop, or Pause. Clean Stop completes the computation
of the current frequency point, then analysis ends. Select Change Priority > (Highest, Above
Normal, Normal, Below Normal, or Lowest Priority), to change the priority of the associated
solution. Altering the priority can be useful when multitasking, to free up resources from a
computationally intensive application. Conversely, it can prevent less important programs from
excessively slowing down the more intensive application.

Continue to View S Matrix Data.

Set Up Solution and Analyze 2-15

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



PDF layout 2-16

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.

Getting Started with HFSS™ 3D Layout: Low Pass Filter



Getting Started with HFSS™ 3D Layout: Low Pass Filter

3 - Evaluate the Results (Post-processing)
Use the post-processing capabilities of Ansys Electronics Desktop to display the results of a
simulation. Also use the export features to save the analysis data (and an equivalent circuit) in
various industry-standard file formats.

The sections in this topic include:

l View S Matrix Data
l Plot Return Loss
l Plot a User-Defined Graph
l Revise p2 Excitation
l Overlay Current Results
l Modify and Animate Current Overlay
l Create Far Field Plot
l Overlay Far Field Plot on Model Geometry
l Frequency Animated Far Field Plot

View S Matrix Data
Follow these instructions to review the scatter matrix (S matrix) data at all sweep frequencies or
at a selected frequency, as well as Y and Z matrix data.

1. From the Project Manager window, right-click Setup1 and selectMatrix Data to open the
Solutions window.
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2. From theMatrix Data tab, ensure the Display All Frequencies and S Matrix boxes are
checked.

3. Navigate to the Format subtab. Then choose the selected data format from the drop-
down menu (i.e.,Magnitude/Phase(deg), dB/Phase(deg), Real, Imaginary,
Magnitude, Phase(deg), or dB).
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4. To see runtime data pertaining to the analysis, navigate to the Profile tab.
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5. To export data, do the following:
a. Navigate to theMatrix Data > Export subtab and click Export Matrix Data to open

an explorer window.
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b. From the explorer window, do the following:
i. Type a File name or use the default (e.g., <ProjectName_DesignName>).
ii. Select a file format from the Save as type drop-down menu (i.e.,

Touchstone (*.sNp), Data Table (spreadsheet) (*.tab), Neutral Model
Format (*.nmf),MATLAB (*.m), or Citifile (*.cit)).

iii. Navigate to an applicable save location. (The default save location is the
folder where the model is saved).

iv. Click Save to save changes, close the explorer window, and return to the
Solution window, or click Cancel to close the explorer window without
exporting anything.
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6. To export the matrix data as an equivalent SPICE model, do the following:
a. From the Export subtab, click Equivalent Circuit Export.

Note: SPICE models require solution data at DC (0Hz) conditions. If there
is no DC frequency value available, a warning will appear.

b. If necessary, click Yes to close warning and open the Equivalent Circuit Export
Options window.
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c. Select an applicable save location, file format, and other equivalent circuit options.
d. ClickOK to save changes, close the Equivalent Circuit Export Options window,

and return to the Solution window, or click Cancel to close the window without
exporting anything.

7. Close the Solutions window.

Continue to Plot Return Loss.
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Plot Return Loss (a Standard Report)
Follow these steps to create a report and plot return loss.

1. From the Project Manager window, right-click Results and select Create Standard
Report > Rectangular Plot to open the Report window.
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2. From the Report window, ensure the following settings are selected:
a. From the Solution drop-down menu, Setup1 : Sweep1.
b. From the Category list, S Parameter.
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c. From theQuantity list, S(p1,p1).
d. From the Function list, dB.

3. Click New Report and the return loss plot opens under the Report window.
4. Close the Report window to view the plot.
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Note:

Return to the plot any time from the Project Manager window (i.e., expand the Project
Tree > [active design folder] > Results folder, and double-click the applicable plot).

Continue to Plot a Smith Chart.

Plot a Smith Chart
A Smith chart is a convenient means of simultaneously displaying multiple parameters (e.g.,
impedance, reflection coefficients, scattering parameters, constant gain contours, et cetera). It is
a useful graphical aid for electronics engineers working in the radio frequency disciplines. Follow
these steps to create a Smith chart.

1. From the Project Manager window, right-click Results and select Create Standard
Report > Smith Chart to open the Report window.
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2. From the Report window, ensure the following settings are selected:
a. From the Solution drop-down menu, Setup1 : Sweep1.
b. From the Category list, S Parameter.

Evaluate the Results (Post-processing) 3-13

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™ 3D Layout: Low Pass Filter

c. From theQuantity list, S(p1,p1).
d. From the Function list, <none>.

3. Click New Report and the return loss plot opens under the Report window.
4. Close the Report window to view the plot.
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Note:

Return to the plot any time from the Project Manager window (i.e., expand the Project
Tree > [active design folder] > Results folder, and double-click the applicable plot).

Continue to Revise An Excitation.

Revise An Excitation
Before creating an overlay of the current results and animating it, alter the edge port definition for
port p2. The default configuration applies an identical 1 volt magnitude excitation at 0 degrees
phase angle to both of the added ports (p1 and p2). Follow these steps to set the p2 excitation to
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0 volts, essentially making p1 the input of the low pass filter and p2 the output, for the purpose of
the overlay.

1. From the Project Manager window, double-click p2 to open the Edge Port Definition
window.

The Edge Port Definition window provides the following configurable settings:

Evaluate the Results (Post-processing) 3-16

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™ 3D Layout: Low Pass Filter

Port Definition area:

l Port Name specifies the port being defined

l Terminal is the name of the terminal (automatic, unfillable field)

l Reference is the Port Solver (Reference) used by the port
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l Calibration Zo is the impedance (equivalent to the Full Port Impedance of the port
(in Ohms))

HFSS area:

l Type of port (automatic, unfillable field)

Post Processing Settings area:

l Magnitude is expressed in Volts (V)

l Phase is expressed in degrees (deg)

l Renormalize Impedance (check to use) is expressed in ohms

Note:

Even if Renormalize Impedance is checked, renormalization is ignored if
it is set to 0. De-embedding is still honored. However, a warning message
appears for all ports with a 0 post-processing renormalization impedance:
Zero impedance on port '<PortName>' is ignored; renormalization is
skipped for this port.

l Deembed Distance (PEM Only) (check to use) is expressed in millimeters (mm)

l Deembed Gap Port Inductance (check to use) specifies the inductance of the
port, which is calculated and cached as part of the solution data for subsequent use.
During post-processing a list of the ports to deembed is used to calibrate the
network data.
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2. From the Post Processing Settings, enter 0V in theMagnitude field:

Continue to Overlay Current Results.

Evaluate the Results (Post-processing) 3-19

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™ 3D Layout: Low Pass Filter

Use Field Overlays
Follow these steps to overlay the magnitude of the surface current results from the trace layer on
the low pass filter.

1. From the Project Manager window, right-click Field Overlays and select Plot Fields > J
> Mag_Jsurf to open the Create Field Plot window.
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Note:

The only Solution available is Setup1 : Sweep2, since only the discrete sweep
type (i.e., Sweep2) has the option to output currents.

2. From the Intrinsic Variables area, select 2.1GHz from the Freq (i.e., frequency) drop-
down menu. 2.1 GHzmost closely corresponds to the point of minimum return loss from
the S Parameter plot.

3. Under the Nets and Layers tab, check the t1 box.
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4. Click Done to save changes, close the Create Field Plot window, and view the overlay.

Continue to Modify and Animated Current Overlay.

Modify and Animate the Current Overlay
Follow these steps to animate the current plot (i.e., Jsurf).

1. From the Layout tab, double-click in the current plot overlay legend to open the (Jsurf)
plot settings window.
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2. From the Color map tab, select Temperature from the Spectrum drop-down menu.

Note:

From this tab, the colors and scale of the plot legend can be modified, if
necessary.

3. Select the Scale tab and do the following:
a. Enter 21 in the Num. Division field.
b. Select Use Limits.
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c. Enter 0.100 in theMin field.
d. Enter 26.000 in theMax field.
e. Select Log to produce a logarithmic scale.
f. Click Apply to save changes.

4. Close the plot settings window.
5. From the Project Manager window, expand Field Overlays > JSurf. Then right-click

Mag_Jsurf1 and click Animate to open the Create Animation Setup window.
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6. From the Create Animation Setup tab, do the following:
a. Ensure Single variable and Phase are selected from the drop-down menus.
b. In the Stop field, enter 350deg.
c. In the Steps field, enter 35.
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Note:

These settings result in an animation with 10° (35deg / 350deg) phase
increments. A 360° phase (360deg) would be identical to the 0° phase, resulting
in a redundant animation frame, and is thus omitted.

7. ClickOK to close the Create Animation Setup window, open an animation control panel,
and start the animation in the Layout Editor.
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8. Use the animation controls to reverse, stop, and change the speed of the animation,
among other settings.

9. From the Layout Editor, Zoom, Rotate, or Pan using the standard Layout Editor
controls.

10. From the animation control panel, click Close to end the animation.

Continue to Create Far Field Plot.

Create Far Field Plot
Far fields are usually not of interest when designing a filter, but the procedure is shown here for
reference. Current outputs are required as the basis of far field computations. Follow these steps
to save field results.

1. Follow these steps to run a discrete frequency sweep:
a. From theOptions area, ensure the Save fields box is checked.
b. Specify multiple discrete frequency points and have the current and field results

available for all specified frequencies.
c. Define the frequency at which the far field results are viewed.
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d. Animate the resulting plot. The animation should progress from one frequency to
the next.

2. Right-click Setup1 and select Properties to open the setup options window.
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3. From the Fields area, check the Save fields box.

Plot Far Field Results
Follow these steps to set up a far field infinite sphere and plot the results.
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1. From the Project Manager window, right-click Radiation and select Insert Far Field
Setup > Infinite Sphere.

The Infinite Sphere Setup window opens.
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2. Make no changes to the default configuration and clickOK to close the Infinite Sphere
window and add the far field setup to the design.

3. Right-click Results and select Create Far Fields Report > 3D Polar Plot to open the
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Report window.
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Note:

In Step 4, the Solution andGeometry drop-down menus pre-select the only available
choices that provide far field results (i.e., Setup1 : Sweep2 is selected from the
Solution drop-down menu, and Infinite Sphere 1 is selected from theGeometry
drop-down menu).

4. Select or ensure the following options are highlighted in the Category,Quantity, and
Function lists:

l Category: rE
l Quantity: rETotal
l Function: <none>
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5. Navigate to the Families tab.
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6. From the Families tab > Freq row, click the button in the Edit column to open a value list.

7. Click 2.1GHz, which corresponds closest to the point of minimum return loss. Then click
outside of the value list to close it.

8. From the Report window, click New Report and the far field plot opens under the Report
window. Close the Report window to access the plot.

9. From the Layout Editor, Zoom, Rotate, or Pan the far field plot using the standard
Layout Editor controls.
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Continue to Overlay Far Field Plot on Model Geometry.

Overlay a Far Field Plot on Model Geometry
To better see how the far field pattern relates to the low pass filter geometry, follow these steps
to overlay the pattern on the model in the Layout Editor.

Note:

If necessary, refocus on the field overlay by expanding the Project Manager window
> Project Tree > [active design folder] > Field Overlays. Then double-click Jsurf.

1. Avoid confusion about the values and units of the far field plot overlay by deactivating the
legend and color contour map. From the Project Manager window, right-clickMag_
Jsurf1 and select Plot Visibility to remove the check. The overlay disappears from the
design in the Layout Editor.
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2. From the Project Manager window, right-click rE Plot1 and select Show In Modeler
Window to overlay the far field plot on the design.
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3. From the Layout Editor, Zoom, Rotate, or Pan using the standard Layout Editor
controls.
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Continue to Frequency Animated Far Field Plot.

Animate a Field Plot
Follow these steps to animate the far field plot to see how fields vary with frequency.

Note:

If necessary, refocus on the far field plot. From the Project Manager window, double-
click rE Plot1.

1. Right-click in the Far Field Plot 1 and select View > Animate to open the Create
Animation Setup window.
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2. Ensure the settings in the Create Animation Setup window match the following image.

Note:

These settings result in an animation with 10° (35deg / 350deg) phase
increments. A 360° phase (360deg) would be identical to the 0° phase, resulting
in a redundant animation frame, and is thus omitted.

3. ClickOK to close the Create Animation Setup window and open the Select Animation
window.
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4. ClickOK to close the Create Animation Setup window and start the animation in the
View tab. Simultaneously, an animation control panel opens.

5. Use the animation controls to Reverse, Stop, and change the speed of the animation, as
needed.

6. If applicable, click+drag the frequency legend to a more desirable location.
7. From the animation control panel, click Close to end the animation.
8. Save the design, either by navigating to File > Save or clicking the Save button on any of

the ribbons.

Congratulations, the HFSS 3D Layout low pass filter getting started guide is complete.
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